Blog

Back to Blog Entries

Trezor v1.3.6

June 27th 2016

The latest release of Trezor firmware, v1.3.6, appears to have broken MultiBit's support of Trezor for Windows users. We have already received a pull request to fix this issue, so expect it to be resolved in our next release.

In the meantime, Trezor users who wish to use MultiBit should downgrade to v1.3.5 until support for Trezor is fixed.

Related articles

Here are some related articles: